SIGABRT on Restore command

Hi,
I tried the “Restore” command of the Engineer a minute ago, and it crashes the game. If I select the Restore command and click on ground, once the Engineer is in range to start “restoring” the ground, the game crashes with a SIGABRT.

I don’t think Spring 1944 supports the Restore command, and I never used it anyway, but it should nevertheless either be removed or do nothing without crashing the game.

Yikes. Thanks for the report.

That is odd, I wonder if it occurs in other content packages on the engine.

Does not occur for BA or Kernel Panic. Though it seems that KP even supports Restore. Gundam RTS and StarWars TA also work with Restore.
MicroModules does not show the Restore option to the user, so it’s not an issue there.

Strange.

I tested it, both on up to date Ubuntu package of 0.80.4 (0.80.4.2-0ubuntu1~9.04~ppa1) and on development version, and neither of them crashes for me.

Which system (Windows/Linux and which version/distribution) and which Spring version are you using?

EDIT: nevermind, found it. Apparently it happens iff map damage is disabled. Was an engine bug; I’ve fixed it now.