problems running in linux

OK, I’m a complete noob in the spring world and I’m usually create mods for glest ( titusgames.de )
I saw this mod/game and really want to try it.
I installed spring/springlobby and so on.
I didn’t install the prorietary data, only this mod and two of its map ( manually.
When I start up the game ( with bot or without bot ) the game loads and the last message I see is
“loading weapon definitions”. Then it goes back to the lobby.

I’m using ubuntu 8.04 with the current Spring release from the spring repository.

whats wrong?

Not sure about linux, but on windows Spring creates a file named infolog.txt and logs various info there. Reasons for crash are usually logged to that file. It may be called differently on linux, but it’s contents will help to debug that problem. Can you post those contents there?
Also, your system specs might be useful, too. Spring tends to exit if some hardware feature it needs is unsupported (although that should be logged into infolog, too).

LogOutput initialized. Available log subsystems: mapinfo, CollisionVolume, unit, VFS-detail, VFS, ArchiveScanner Enabled log subsystems: Enable or disable log subsystems using the LogSubsystems configuration key or the SPRING_LOG_SUBSYSTEMS environment variable (both comma separated). Using script /home/tscharn/springdata//script.txt using configuration source "/home/tscharn/.springrc" OS: Linux Using read-write data directory: /home/tscharn/springdata/ Using read-only data directory: /home/tscharn/.spring/ Using read-only data directory: /usr/share/games/spring/ Using read-only data directory: /usr/lib/spring/ Scanning: /usr/lib/spring/maps Scanning: /usr/lib/spring/base Scanning: /usr/lib/spring/mods Scanning: /usr/share/games/spring/maps Scanning: /usr/share/games/spring/base Scanning: /usr/share/games/spring/mods Scanning: /home/tscharn/.spring/maps Scanning: /home/tscharn/.spring/base Scanning: /home/tscharn/.spring/mods Scanning: /home/tscharn/springdata/maps Scanning: /home/tscharn/springdata/base Scanning: /home/tscharn/springdata/mods Video mode set to 1024 x 768 / 32 bit [ 0] SDL: 1.2.12 [ 0] GL: 2.1.2 NVIDIA 173.14.12 [ 0] GL: NVIDIA Corporation [ 0] GL: GeForce 7600 GS/PCI/SSE2/3DNOW! [ 0] GLEW: 1.5.0 [ 0] Connecting to local server [ 0] Starting demo recording [ 0] Using map 1944_Kiev_V4.smf [ 0] Recording demo demos/20090210_205926_1944_Kiev_V4_0.78.2.sdf [ 0] Using script Commanders [ 0] Using mod Spring: 1944 Operation Konstantin (v0.92) [ 0] Using mod archive S44Konstantin_v092.sdz [ 0] Became player 0 (team 0, allyteam 0) [ 0] OpenAL: 1.1 [ 0] OpenAL: ALC_EXT_capture AL_EXT_capture AL_EXT_vorbis AL_EXT_MP3 AL_LOKI_quadriphonic AL_LOKI_play_position AL_LOKI_WAVE_format AL_LOKI_IMA_ADPCM_format AL_LOKI_buffer_data_callback ALC_LOKI_audio_channel [ 0] OpenAL: sounds/button9.wav has data length 291939 greater than actual data length 866 [ 0] Parsing unit icons [ 0] Loading all definitions: 0.610000 [ 0] You are missing the "ARB_shadow_ambient" extension (this will probably make shadows darker than they should be) [ 0] Opening map file [ 0] Loading Map [ 0] Loading detail textures [ 0] Creating overhead texture [ 0] Creating ground shading [ 0] Loading tile file [ 0] Reading tiles [ 0] Reading tile map [ 0] Creating projectile texture [ 0] Number of damage types: 14 [ 0] Loading weapon definitions [ 0] OpenAL: sounds/US_76mm.wav has data length 291939 greater than actual data length 119950 [ 0] OpenAL: sounds/GEN_Explo_1.wav has data length 291939 greater than actual data length 111470 [ 0] OpenAL: sounds/GEN_Explo_3.wav has data length 291939 greater than actual data length 86666 [ 0] OpenAL: sounds/US_37mm.wav has data length 291939 greater than actual data length 76478 [ 0] OpenAL: sounds/RUS_45mm.wav has data length 291939 greater than actual data length 71202 [ 0] OpenAL: sounds/GEN_Explo_2.wav has data length 291939 greater than actual data length 146062 [ 0] OpenAL: sounds/GEN_105mm.wav has data length 291939 greater than actual data length 132652 [ 0] OpenAL: sounds/GEN_37mmAA.wav has data length 291939 greater than actual data length 27194 [ 0] OpenAL: sounds/GEN_Explo_Flak1.wav has data length 291939 greater than actual data length 36052 [ 0] OpenAL: sounds/GER_50mm.wav has data length 291939 greater than actual data length 51342 [ 0] OpenAL: sounds/RUS_85mm.wav has data length 291939 greater than actual data length 156028 [ 0] OpenAL: sounds/RUS_122mm.wav has data length 291939 greater than actual data length 78024 [ 0] OpenAL: sounds/RUS_DP.wav has data length 291939 greater than actual data length 187582 [ 0] OpenAL: sounds/RUS_76mm.wav has data length 291939 greater than actual data length 132652 [ 0] OpenAL: sounds/GEN_Explo_Flag.wav has data length 291939 greater than actual data length 66754 [ 0] OpenAL: sounds/GER_20mm.wav has data length 291939 greater than actual data length 25678 [ 0] OpenAL: sounds/GEN_Explo_10.wav has data length 291939 greater than actual data length 211558 [ 0] OpenAL: sounds/GER_75mm.wav has data length 291939 greater than actual data length 53584 [ 0] OpenAL: sounds/GER_75mmLong.wav has data length 291939 greater than actual data length 132652 [ 0] OpenAL: sounds/GEN_Explo_5.wav has data length 291939 greater than actual data length 259168

Thats it, I don’t see any error in it?
Or does something like this means trouble:

OpenAL: sounds/GEN_Explo_Flag.wav has data length 291939 greater than actual data length 66754

Guy did you do the following:

did you add the paketsource?

deb http://ppa.launchpad.net/spring/ppa/ubuntu hardy main

Then did you download this with the packetmanager?

You can install this optional:

?

yes, thats what I did. ( by the way I had to add the gpg-key too, whats not described in springs installation description )
But I didn’t add the optional things, because I only want to play this mod here.
Should I install these optional things too?

Looks a bit like our problem with sounds on linux, it was supposed to be fixed in the new installer. I’m not sure the sdz mod file contains the fix though.

no, its not fixed in the installer - we’re in the process of replacing and fixing all the sounds. hopefully it’ll be done soonish and it’ll go along with the aircraft release.

thanks for all the quick replies, I will wait very curiously for the new release with fixed sounds!
( probably I will try to fix the wav files myself, but I think I have to learn some spring details before …)

well i didnt add the key xD i got a error message thats all but it worked, okay do the following install another mod and watch if this work. If no one had this idea before me…Anyway its a while ago that i played this on Ubuntu Intrepid Ibex, i will try it on weekend but iam sure that it will work xD idk why… you use Hardy Heron? maybe update but i dont think it will take a effect or maybe delete Spring completly and install all new maybe that help. Well if it works at my pc i will let you know. Oh and maybe UPDATE your video Card driver :stuck_out_tongue: to 177.XX

(I used windows in the last 2 weeks xD)

titi: you can work around it by creating a folder ~/.spring/sounds, and putting the old GEN_Flamethrower.wav sound inside it.

Run in a terminal:

mkdir ~/.spring/sounds
cd ~/.spring/sounds
wget 'http://tinyurl.com/GEN-Flamethrower-wav' -O GEN_Flamethrower.wav

Then, when a new releases comes out, you can erase this sound and check if it already works without workaround.

THANKS :slight_smile:
It works, its indeed only the GEN_Flamethrower.wav which causes the problem.
I don’t have time today to look at it, but it works and looks good!

thanks works for me too!!!