94.1 + r3824


#1

Players: JAL, zCram
Map: 1944_Village_Crossing_v2
Spring: 94.1 single
S44: svnr3824(new)

A bit longer game of those that we had, with me playing the soviets. Unloading transport trucks sometimes makes inf fly over to the other side of the map… We had a few ruined games because of that earlier; when properly placeing the unload, my rifilemen could fly to his base and blow all the energy storages up.

Can someone make an instruction page of how to kkickstart the ~/.spring/mods/S44Main.sdd directory equivalent in windows, with windows svn clients and such? This’d be for noobs. Have no idea of how that works, and there are a lot of people that pop bye and can’t have a go because the svn versions is all we can play nowadays.

And the greetz go out to: FLOZi, Yuri4b, NoBoDYnEm0 and SpeedyNEDDIE (for making the game); and the folks out on #sy for f*****g the engine up for us. At least s44 doesn’t now completely work on MacOS, too, in addition to Windows, Linux and FreeBSD. GG!

Oh and this server said “413 Request Entity Too Large nginx/1.1.19” When I tried to upload a 1.3M replay (this very same one). Didn’t work

urki.anapnea.net/tmp/20130616_23 … _v2_94.sdf


#2

I would really love an update on the “How to get the svn” instructions… I can’t get around it with my tortoisesvn client, it wont accept the link at sourceforge.


#3

It’s this address now, I believe:

https://svn.code.sf.net/p/spring1944/code/trunk/S44Main.sdd

How to make the deal work out on windows, beats me. For *nix it’s just two lines,

$ cd ~/.spring/mods/
$ svn co https://svn.code.sf.net/p/spring1944/code/trunk/S44Main.sdd

,and to update later,

$ cd ~/.spring/mods/S44Main.sdd
$ svn up

But for win32 you have to click about on a couple-o-dozen application windows in an uninteresting manner for a few minutes.
Someone also complained about tortoise asking for a password for this repository at sf. But it is a zero-length one (empty) for public checkout… so there actually is no password.


#4

yeah that’s the link I’ve tried… I guess I’ll just use another SVN client than tortoise to try.
Thanks for the info z.

EDIT: No it wasn’t! I’m updated now! YEAH!
I’ve been trying these that sourceforge provided, and none ever worked.
svn checkout svn://svn.code.sf.net/p/spring1944/code/trunk spring1944-code
svn checkout svn.code.sf.net/p/spring1944/code/trunk spring1944-code


#5

ok, consider me shamed into activity >_< I’ve been doing all my spare-time programming on a mac, and spring’s borked enough there that inertia tends to keep me from doing S44 stuff.

there’s a fix in svn for the flying transport truck inf? if so I can make and release a build tonight, most likely. if not, perhaps I’ll be able to poke at it this weekend. not too keen on replacing engine transport stuff with lua, though.


#6

My reaction when I read the part of trying to fix the flying inf:
But, I know spring is borked, you guys really don’t have to shame on anything or try anything for the moment… I just hope spring pre v81 version 2 comes back soon.
EDIT: At least for me those versions worked like a charm, pathing-wise, etc.


#7

doesn’t look like SVN is in any better shape in this regard, so I’ll have to wait until the weekend to see about a fix. sorry things have languished so much, most of the random times I’ve logged in, #s44 is empty, so I assume pretty much nobody is playing.


#8

My friends didn’t like to see flying men and warping maxims, that’s why less games are played, but fear not, next term I will make the first tyrannic rule in Gamers club, to have a game of s44 every week; I shall be remembered for my noble dictatorship, leading these short-sighted casual players to the glory of s44! :no4:
I guess I’m waaay past my bedtime. :unamused:


#9

IIRC from a month ago that fix works with an engine that is not yet released


#10

hm, yuck. and this problem specifically impacts S44, not other mods with transports? we don’t do anything especially fancy with our transport units that I recall. at any rate, if it really came down to it I could probably whip up a Lua-ized replacement, I’d just prefer not to if possible.


#11

It may have something to do with our units (inf) having lower mass than most, esp. truck mass/inf mass ratio (which probably caused insane impulse transfer after engine change)


#12

unfortunately neither mass nor pushResistant-ness in the inf definitions had any effect. I did a bit of reading on the forums and didn’t immediately see other mods with similar issues. I thought perhaps it had to do with the orientation of the transport unit or units being unloaded into terrain and pushed out of it, but I’m still not sure.

any clues much appreciated.


#13

Yeah no fix, tried a few things I thought it might be but no dice.

Best to make a mantis if you can give clear steps how to reproduce it, Nemo.


#14

Gliders!
Should’ve been active earlier on. Still not very proficient with RUSfaction.

urki.anapnea.net/tmp/20130622_23 … _v2_94.sdf


#15

I finally got a chance to watch this last one. …yow! what an excellent game. at least four times I started speeding up the demo, thinking that the end was near and clearly predictable…only to have things turn around entirely.

zCram/buumi, thank you so much for that - that was a load of fun to watch. hope you guys had a blast playing it, even if you must have been a bit exhausted by the end.


#16

Thanks. A bit too long replay for recommending to anyone for watching, actually.
You were having trouble with getting the replay to show. How did that problem get resolved?


#17

Got spring running natively on OSX, instead of trying to run it inside a linux VM.


#18

spring: 94.1 single, official static linked lenooks
s44: r3835 (svn)(new)
players: zCram, Buumi
map: 1944_Village_Crossing_v2
storyline: flying inf
replay: urki.anapnea.net/tmp/20130730_01 … _v2_94.sdf 1340022 bytes; 40min


#19

Were the flying inf around the 15-20 minute mark? I didn’t see any, but after that it started becoming increasingly clear that the simulation was out of sync (lots of unused dudes piling up at rally points, some inexplicably foolish commands, unused factories…).

It was great fun to watch the first 15 though…


#20

Replays on 94.1 are incompatible between windows and linux, maybe that’s the problem (we found that out while reporting flying inf bug: mantis link)